下载  >  开发技术  >  C++  > windows下Qt的mysql驱动

windows下Qt的mysql驱动 评分:

适用于windows下Qt开发。 由于Qt默认没有mysql驱动,所以当你一连接mysql就会报错。 这个版本支持Qt5.1.1版本。

...展开详情
2013-12-05 上传 大小:1006KB
举报 收藏
分享

评论 下载该资源后可以进行评论 共3条

qq849635649 经测试,能用,没问题
2015-07-13
回复
zjyggxm 可以使用,省的自己编了,不错
2014-10-08
回复
ustcwudi 可以用,不错
2014-08-05
回复
Qt Mysql驱动编译过程以及驱动下载

NULL 博文链接:https://qimo601.iteye.com/blog/1465599

立即下载
Qt5.7 MySQL驱动

假设~为Qt的安装目录(例如:C:\Qt\Qt5.9.7\5.9.7) 1、将libmysql.lib和libmysql.dll复制到~\mingw53_32\bin目录下。 2、将qsqlmysql.dll和qsqlmysqld.dll复制到~\mingw53_32\plugins\sqldrivers目录下。 注: A、如果可以,应尽量保证版本一致。 B、如果版本不能保证完全一致,可选择比你的qt版本低,且最接近你的qt版本的mysql 驱动,尝试无误后使用。(一般来说,软件会保持高版本向低版本兼容的特性,通常接 近的几个版本是可以通用的)

立即下载
Qt5.7及以上高版本加载mysql的驱动文件

Ubuntu下高版本的Qt,默认的mysql驱动不能用,需要下载Qtmysql源码进行编译驱动,我这个自己编译好了,大家可以拿来直接用,因为源码很占空间,要是非要自己编译可以参考这个https://blog.csdn.net/zjx18915341085/article/details/79570883

立即下载
qt5.7.1需要的mysql驱动文件

使用qt5.7版本链接mysql数据库,出现的驱动问题,需要重新编译源码,为了大家的方便,特此把编译过后能用的so文件提供出来

立即下载
Qt Mysql驱动

刚开始也不会弄,找了好多资料才整出来的,呵呵 这个是自己编译的,QT是qt-sdk-win-opensource-2009.05.exe(NOKIA出的) 编译器为Mingw MYSQL是5.1版本 其它环境还没测试过,不好意思

立即下载